const regex = /((<style>)|(<style\s+type=(?:".*"|'.*')\/?)|(<\/style>))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((<style>)|(<style\\s+type=(?:".*"|\'.*\')\\\/?)|(<\\\/style>))', 'g')
const str = `<style>
<style type='text/css'/>
<style type="text/css">
styles
</style>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}