$re = '/((<style>)|(<style\s+type=(?:".*"|\'.*\')\/?)|(<\/style>))/';
$str = '<style>
<style type=\'text/css\'/>
<style type="text/css">
styles
</style>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);