re = /((<style>)|(<style\s+type=(?:".*"|'.*')\/?)|(<\/style>))/
str = '<style>
<style type=\'text/css\'/>
<style type="text/css">
styles
</style>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end