package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\((?:[^)(]*(?R)?)*+\)|\{(?:[^}{]*+(?R)?)*\}|\[(?:[^][]*+(?R)?)*\]`)
var str = `Hello [123] {45} world (67) Hello There (8) [9] {0}
(deep(nested[in{f(u)[n](n)y}]){[brackets]}) - [this] (will) not (break)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}