import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\((?:[^)(]*(?R)?)*+\\)|\\{(?:[^\\}\\{]*+(?R)?)*\\}|\\[(?:[^][]*+(?R)?)*\\]";
final String string = "Hello [123] {45} world (67) Hello There (8) [9] {0}\n"
+ "(deep(nested[in{f(u)[n](n)y}]){[brackets]}) - [this] (will) not (break)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}