$re = '/\((?:[^)(]*(?R)?)*+\)|\{(?:[^}{]*+(?R)?)*\}|\[(?:[^][]*+(?R)?)*\]/m';
$str = 'Hello [123] {45} world (67) Hello There (8) [9] {0}
(deep(nested[in{f(u)[n](n)y}]){[brackets]}) - [this] (will) not (break)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);