import re
regex = re.compile(r"\((?:[^)(]*(?R)?)*+\)|\{(?:[^}{]*+(?R)?)*\}|\[(?:[^][]*+(?R)?)*\]", flags=re.MULTILINE)
test_str = ("Hello [123] {45} world (67) Hello There (8) [9] {0}\n"
"(deep(nested[in{f(u)[n](n)y}]){[brackets]}) - [this] (will) not (break)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")