package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\((?:[^)(]*(?1)?)*+\)|\{(?:[^}{]*+(?1)?)*\}|\[(?:[^][]*+(?1)?)*\])(*SKIP)(*F)|[^][(){}]+`)
var str = `Hello [123] {45(123)} world (67) Hello There (8) [9] {0}
(deep(nested[in{f(u)[n](n)y}]){[brackets]}) - [this] (will) not (break)`
var substitution = " "
fmt.Println(re.ReplaceAllString(str, substitution))
}