import re
regex = re.compile(r"(\((?:[^)(]*(?1)?)*+\)|\{(?:[^}{]*+(?1)?)*\}|\[(?:[^][]*+(?1)?)*\])(*SKIP)(*F)|[^][(){}]+", flags=re.MULTILINE)
test_str = ("Hello [123] {45(123)} world (67) Hello There (8) [9] {0}\n"
"(deep(nested[in{f(u)[n](n)y}]){[brackets]}) - [this] (will) not (break)")
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)