$re = '/(\((?:[^)(]*(?1)?)*+\)|\{(?:[^}{]*+(?1)?)*\}|\[(?:[^][]*+(?1)?)*\])(*SKIP)(*F)|[^][(){}]+/m';
$str = 'Hello [123] {45(123)} world (67) Hello There (8) [9] {0}
(deep(nested[in{f(u)[n](n)y}]){[brackets]}) - [this] (will) not (break)';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;