use strict;
my $str = 'Hello [123] {45(123)} world (67) Hello There (8) [9] {0}
(deep(nested[in{f(u)[n](n)y}]){[brackets]}) - [this] (will) not (break)';
my $regex = qr/(\((?:[^)(]*(?1)?)*+\)|\{(?:[^}{]*+(?1)?)*\}|\[(?:[^][]*+(?1)?)*\])(*SKIP)(*F)|[^][(){}]+/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";