package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)\((?:[^()]+|(?R))*+\)`)
var str = `Hey! ( (Look,) (ma!) ( (no) r(e(c(u(r)s)i)o)n!! ) ) Woooo
( Matches (can (even
span ) multiple )
lines! ) yeah buddy!!
(((((((()(((((()(((((( NO LIMITS!!! ))))))())))))()))))))))))))`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}