re = /(?s)\((?:[^()]+|(?R))*+\)/
str = 'Hey! ( (Look,) (ma!) ( (no) r(e(c(u(r)s)i)o)n!! ) ) Woooo
( Matches (can (even
span ) multiple )
lines! ) yeah buddy!!
(((((((()(((((()(((((( NO LIMITS!!! ))))))())))))()))))))))))))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end