// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)\((?:[^()]+|(?R))*+\)").unwrap();
let string = "Hey! ( (Look,) (ma!) ( (no) r(e(c(u(r)s)i)o)n!! ) ) Woooo
( Matches (can (even
span ) multiple )
lines! ) yeah buddy!!
(((((((()(((((()(((((( NO LIMITS!!! ))))))())))))()))))))))))))";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}