import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)\\((?:[^()]+|(?R))*+\\)";
final String string = "Hey! ( (Look,) (ma!) ( (no) r(e(c(u(r)s)i)o)n!! ) ) Woooo\n"
+ "( Matches (can (even\n"
+ "span ) multiple ) \n"
+ "lines! ) yeah buddy!!\n"
+ "(((((((()(((((()(((((( NO LIMITS!!! ))))))())))))()))))))))))))";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}