#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)^\d{5,6}[\r\n]*.*?^new version:[^\r\n]*"
Local $sString = "96545" & @CRLF & _
"this is some changes in the ticket" & @CRLF & _
"some new version: x.x.22" & @CRLF & _
"another change" & @CRLF & _
"new version: x.y.2.2" & @CRLF & _
"120091" & @CRLF & _
"this is some changes in the ticket" & @CRLF & _
"some new version: z.z.22" & @CRLF & _
"another change" & @CRLF & _
"another change" & @CRLF & _
"another change" & @CRLF & _
"new version: z.y.2.2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")