import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{5,6}[\\r\\n]*.*?^new version:[^\\r\\n]*";
final String string = "96545\n"
+ "this is some changes in the ticket\n"
+ "some new version: x.x.22\n"
+ "another change\n"
+ "new version: x.y.2.2\n"
+ "120091\n"
+ "this is some changes in the ticket\n"
+ "some new version: z.z.22\n"
+ "another change\n"
+ "another change\n"
+ "another change\n"
+ "new version: z.y.2.2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}