# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\d{5,6}[\r\n]*.*?^new version:[^\r\n]*"
test_str = ("96545\n"
"this is some changes in the ticket\n"
"some new version: x.x.22\n"
"another change\n"
"new version: x.y.2.2\n"
"120091\n"
"this is some changes in the ticket\n"
"some new version: z.z.22\n"
"another change\n"
"another change\n"
"another change\n"
"new version: z.y.2.2")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.