re = /^\d{5,6}[\r\n]*.*?^new version:[^\r\n]*/m
str = '96545
this is some changes in the ticket
some new version: x.x.22
another change
new version: x.y.2.2
120091
this is some changes in the ticket
some new version: z.z.22
another change
another change
another change
new version: z.y.2.2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end