#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)select id='(?:.*)' (?:\D+(?<=option value=')(.*)')*"
Local $sString = "select id='name' method='out'" & @CRLF & _
"" & @CRLF & _
"option value='1'" & @CRLF & _
"" & @CRLF & _
"option value='2'" & @CRLF & _
"" & @CRLF & _
"option value='3'" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")