re = /select id='(?:.*)' (?:\D+(?<=option value=')(.*)')*/m
str = 'select id=\'name\' method=\'out\'
option value=\'1\'
option value=\'2\'
option value=\'3\'
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end