using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"select id='(?:.*)' (?:\D+(?<=option value=')(.*)')*";
string input = @"select id='name' method='out'
option value='1'
option value='2'
option value='3'
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}