import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "select id='(?:.*)' (?:\\D+(?<=option value=')(.*)')*";
final String string = "select id='name' method='out'\n\n"
+ "option value='1'\n\n"
+ "option value='2'\n\n"
+ "option value='3'\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}