package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(1\.30\.(1[0-9]|[2-9][0-9])|2\.[01]\.[0-4])`)
var str = `1.30.10
1.30.11
2.0.0
2.1.0
2.1.4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}