$re = '/^(1\.30\.(1[0-9]|[2-9][0-9])|2\.[01]\.[0-4])/m';
$str = '1.30.10
1.30.11
2.0.0
2.1.0
2.1.4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);