const regex = /^(1\.30\.(1[0-9]|[2-9][0-9])|2\.[01]\.[0-4])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(1\\.30\\.(1[0-9]|[2-9][0-9])|2\\.[01]\\.[0-4])', 'gm')
const str = `1.30.10
1.30.11
2.0.0
2.1.0
2.1.4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}