import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(1\\.30\\.(1[0-9]|[2-9][0-9])|2\\.[01]\\.[0-4])";
final String string = "1.30.10\n"
+ "1.30.11\n"
+ "2.0.0\n"
+ "2.1.0\n"
+ "2.1.4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}