#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\s\S]*\b(\d+)"
Local $sString = "My ID is 112243 and my phone number is 0987654321. Thanks you." & @CRLF & _
"My ID is 112243 and my phone number is 0987654321. Thanks you." & @CRLF & _
"My ID is 112243 and my phone number is 0987654321. Thanks you."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")