using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\s\S]*\b(\d+)";
string input = @"My ID is 112243 and my phone number is 0987654321. Thanks you.
My ID is 112243 and my phone number is 0987654321. Thanks you.
My ID is 112243 and my phone number is 0987654321. Thanks you.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}