package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\s\S]*\b(\d+)`)
var str = `My ID is 112243 and my phone number is 0987654321. Thanks you.
My ID is 112243 and my phone number is 0987654321. Thanks you.
My ID is 112243 and my phone number is 0987654321. Thanks you.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}