import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?&valid_text)(?(DEFINE)\n"
+ " (?<valid_text>\n"
+ " \\A\\s*(?&version)\\s*\n"
+ " (?: (?&element) \\s* )+\n"
+ " \\s*\\Z\n"
+ " )\n"
+ " (?<version>\n"
+ " version\\(.+?\\);\n"
+ " )\n"
+ " (?<element>\n"
+ " element\\s*\n"
+ " (?&element_body);\n"
+ " )\n"
+ " (?<element_body>\n"
+ " \\( (?: [^()]++ | (?&element_body) )* \\)\n"
+ " )\n"
+ ")";
final String string = "version();\n\n"
+ "element\n"
+ "(\n"
+ ");\n\n"
+ "garbage <--- THIS SHOULD NOT MATCH!\n\n"
+ "element\n"
+ "(\n"
+ ");\n\n"
+ "element\n"
+ "(\n"
+ ");";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}