const regex = /(?&valid_text)(?(DEFINE)
(?<valid_text>
\A\s*(?&version)\s*
(?: (?&element) \s* )+
\s*\Z
)
(?<version>
version\(.+?\);
)
(?<element>
element\s*
(?&element_body);
)
(?<element_body>
\( (?: [^()]++ | (?&element_body) )* \)
)
)/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?&valid_text)(?(DEFINE)
(?<valid_text>
\\A\\s*(?&version)\\s*
(?: (?&element) \\s* )+
\\s*\\Z
)
(?<version>
version\\(.+?\\);
)
(?<element>
element\\s*
(?&element_body);
)
(?<element_body>
\\( (?: [^()]++ | (?&element_body) )* \\)
)
)', 'gms')
const str = `version();
element
(
);
garbage <--- THIS SHOULD NOT MATCH!
element
(
);
element
(
);`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}