package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\(([^(){},]+|\((?:[^(),]+,[^(),]+)\)|({(?:[^{}]+|(?-1))++}))(?:,(?2))+),`)
var str = `Should work for:
(1,2,3)
(1,2,3,4)
((1,2),3,4)
(((1,2,3),4),5)
({x},{y},{z})
(1,(2,3),4)
((1,2),(3,4),5)
((1,2),3,(4,5))
(1,(2,(3,4),5))
(1,(2,({3},4),5))
(1,{{1},{1,2}},3)
Should not work for:
(1,2)
(10,10)
(1,10)
((1,2),3)
(((1,1),1),1)
({0},1)
({{x},{x,y}},z)`
var substitution = "($1),"
fmt.Println(re.ReplaceAllString(str, substitution))
}