re = /(\(([^(){},]+|\((?:[^(),]+,[^(),]+)\)|({(?:[^{}]+|(?-1))++}))(?:,(?2))+),/m
str = 'Should work for:
(1,2,3)
(1,2,3,4)
((1,2),3,4)
(((1,2,3),4),5)
({x},{y},{z})
(1,(2,3),4)
((1,2),(3,4),5)
((1,2),3,(4,5))
(1,(2,(3,4),5))
(1,(2,({3},4),5))
(1,{{1},{1,2}},3)
Should not work for:
(1,2)
(10,10)
(1,10)
((1,2),3)
(((1,1),1),1)
({0},1)
({{x},{x,y}},z)'
subst = '($1),'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result