// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\(([^(){},]+|\((?:[^(),]+,[^(),]+)\)|({(?:[^{}]+|(?-1))++}))(?:,(?2))+),").unwrap();
let string = "Should work for:
(1,2,3)
(1,2,3,4)
((1,2),3,4)
(((1,2,3),4),5)
({x},{y},{z})
(1,(2,3),4)
((1,2),(3,4),5)
((1,2),3,(4,5))
(1,(2,(3,4),5))
(1,(2,({3},4),5))
(1,{{1},{1,2}},3)
Should not work for:
(1,2)
(10,10)
(1,10)
((1,2),3)
(((1,1),1),1)
({0},1)
({{x},{x,y}},z)";
let substitution = "($1),";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}