using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z0-9.]*:(?!jar)";
string input = @"com.test.api:super.duper-api:jar:1.2.3:compile
super.duper.api:jar:1.2.3:compile
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}