const regex = /^[a-z0-9.]*:(?!jar)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z0-9.]*:(?!jar)', 'gm')
const str = `com.test.api:super.duper-api:jar:1.2.3:compile
super.duper.api:jar:1.2.3:compile
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}