re = /^[a-z0-9.]*:(?!jar)/m
str = 'com.test.api:super.duper-api:jar:1.2.3:compile
super.duper.api:jar:1.2.3:compile
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end