const regex = /\s+(?=(?:(?:[^"]*"){2})*[^"]*+$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s+(?=(?:(?:[^"]*"){2})*[^"]*+$)', 'gm')
const str = `{
"1": "This is a string",
"AnInt": 123,
"3": [6, 9, 429]
}`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);