import re
regex = re.compile(r"\s+(?=(?:(?:[^\"]*\"){2})*[^\"]*+$)", flags=re.MULTILINE)
test_str = ("{\n"
" \"1\": \"This is a string\",\n"
" \"AnInt\": 123,\n"
" \"3\": [6, 9, 429]\n"
"}")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)