import Foundation
let pattern = #"\s+(?=(?:(?:[^"]*"){2})*[^"]*+$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{
"1": "This is a string",
"AnInt": 123,
"3": [6, 9, 429]
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)