use strict;
my $str = '{
"1": "This is a string",
"AnInt": 123,
"3": [6, 9, 429]
}';
my $regex = qr/\s+(?=(?:(?:[^"]*"){2})*[^"]*+$)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";