package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)food/(.+?)/([^/]+)-recipes/?$`)
var str = `food/onion/onion-recipes
food/onion/onion-recipes/
food/onion/child/child-recipes
food/onion/child/child-recipes/
food/onion/onion-blablah`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}