$re = '#food/(.+?)/([^/]+)-recipes/?$#m';
$str = 'food/onion/onion-recipes
food/onion/onion-recipes/
food/onion/child/child-recipes
food/onion/child/child-recipes/
food/onion/onion-blablah';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);