import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)(?(?=\\A).*?<script[^>]*>).*?(?:\\K\\/\\/|<\\/script>.*?(?:<script[^>]*>|\\z)(*SKIP)(*FAIL))";
final String string = "Goal: Search using regex (in PowerShell) to find and highlight the JS comments within HTML script tags.\n\n"
+ "TEST#1:\n"
+ "don't match // dont find this comment here\n"
+ "don't match https://somesite.com\n\n"
+ "<script>\n"
+ "// find this comment here\n"
+ "//find this comment here\n"
+ "</script>\n\n\n"
+ "TEST#2:\n"
+ "<script>\n"
+ "passover //find this comment here\n"
+ "</script>\n\n\n"
+ "TEST#3:\n"
+ "<script>\n"
+ "// find this comment here\n"
+ "</script>\n"
+ "// dont find this comment here\n\n\n"
+ "TEST#4:\n"
+ "<script>\n"
+ "passover\n"
+ "// find this comment here\n"
+ "passover\n"
+ "//find this comment here\n"
+ "</script>\n"
+ "//dont find this comment here\n\n\n"
+ "TEST#5:\n"
+ "<script>\n"
+ "passover\n"
+ "https://somesite.com\n"
+ "dont find url\n"
+ "passover\n"
+ "</script>\n\n\n"
+ "TEST#6:\n"
+ "<script passover>\n"
+ "passover\n"
+ "// find this comment here\n"
+ "passover\n"
+ "passover\n"
+ "//find this comment here\n"
+ "</script>\n\n\n"
+ "TEST#7:\n"
+ "<ScRiPt>\n"
+ "passover //find this comment here with this included also!\n"
+ "passover this text\n"
+ "</sCrIpT>\n\n"
+ "//dont find this comment here\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}