use strict;
my $str = 'Goal: Search using regex (in PowerShell) to find and highlight the JS comments within HTML script tags.
TEST#1:
don\'t match // dont find this comment here
don\'t match https://somesite.com
<script>
// find this comment here
//find this comment here
</script>
TEST#2:
<script>
passover //find this comment here
</script>
TEST#3:
<script>
// find this comment here
</script>
// dont find this comment here
TEST#4:
<script>
passover
// find this comment here
passover
//find this comment here
</script>
//dont find this comment here
TEST#5:
<script>
passover
https://somesite.com
dont find url
passover
</script>
TEST#6:
<script passover>
passover
// find this comment here
passover
passover
//find this comment here
</script>
TEST#7:
<ScRiPt>
passover //find this comment here with this included also!
passover this text
</sCrIpT>
//dont find this comment here
';
my $regex = qr/(?s)(?(?=\A).*?<script[^>]*>).*?(?:\K\/\/|<\/script>.*?(?:<script[^>]*>|\z)(*SKIP)(*FAIL))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}