re = /(?s)(?(?=\A).*?<script[^>]*>).*?(?:\K\/\/|<\/script>.*?(?:<script[^>]*>|\z)(*SKIP)(*FAIL))/m
str = 'Goal: Search using regex (in PowerShell) to find and highlight the JS comments within HTML script tags.
TEST#1:
don\'t match // dont find this comment here
don\'t match https://somesite.com
<script>
// find this comment here
//find this comment here
</script>
TEST#2:
<script>
passover //find this comment here
</script>
TEST#3:
<script>
// find this comment here
</script>
// dont find this comment here
TEST#4:
<script>
passover
// find this comment here
passover
//find this comment here
</script>
//dont find this comment here
TEST#5:
<script>
passover
https://somesite.com
dont find url
passover
</script>
TEST#6:
<script passover>
passover
// find this comment here
passover
passover
//find this comment here
</script>
TEST#7:
<ScRiPt>
passover //find this comment here with this included also!
passover this text
</sCrIpT>
//dont find this comment here
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end