import Foundation
let pattern = #"(?s)(?(?=\A).*?<script[^>]*>).*?(?:\K\/\/|<\/script>.*?(?:<script[^>]*>|\z)(*SKIP)(*FAIL))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
Goal: Search using regex (in PowerShell) to find and highlight the JS comments within HTML script tags.
TEST#1:
don't match // dont find this comment here
don't match https://somesite.com
<script>
// find this comment here
//find this comment here
</script>
TEST#2:
<script>
passover //find this comment here
</script>
TEST#3:
<script>
// find this comment here
</script>
// dont find this comment here
TEST#4:
<script>
passover
// find this comment here
passover
//find this comment here
</script>
//dont find this comment here
TEST#5:
<script>
passover
https://somesite.com
dont find url
passover
</script>
TEST#6:
<script passover>
passover
// find this comment here
passover
passover
//find this comment here
</script>
TEST#7:
<ScRiPt>
passover //find this comment here with this included also!
passover this text
</sCrIpT>
//dont find this comment here
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)