package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^,]+),`)
var str = `1,,000.23
0,9
0.0
,55,55555,5555
`
var substitution = "$1."
fmt.Println(re.ReplaceAllString(str, substitution))
}