$re = '/^([^,]+),/m';
$str = '1,,000.23
0,9
0.0
,55,55555,5555
';
$subst = "$1.";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;